Getting Started with Intel® Galileo Gen2

This guide explains how to get started with your Intel® Galileo Gen2.

Quick Start

The Intel® Galileo Gen2 board is programmed using the Arduino Software (IDE), our Integrated Development Environment common to all our boards. You should have already it installed on your PC, as explained in the home page of our Getting Started.

Install the i586 Core

The next step requires the addition of the Intel® Galileo Gen2 Core to the Arduino Software (IDE). This simple procedure is done selecting Tools menu, then Boards and last Boards Manager. Select Arduino Certified as type and then click on the Intel i586 boards by Intel. Select the latest core and then Install.


When the process is completed, the Intel Galileo Gen2 board will be available in the boards list.

Connect the board to your PC

To avoid damage to your Intel® Galileo Gen2, always apply power to the board via the included power supply before connecting to your computer via USB. Once the board is connected to power, connect the Galileo to your computer with a microUSB cable.

Load the blink example

Load the LED blink example sketch: File > Examples > 1.Basics > Blink.


Select your board

You'll need to select the Intel® Galileo Gen 2 in the Tools > Board menu as shown below:


Select your serial port

Select the serial device of the board from the Tools > Serial Port menu. The easiest way to find what port the board is using is by disconnecting your board, restarting the IDE, and re-opening the menu; the entry that disappears should be the Intel® Galielo Gen 2 board. Reconnect the board, restart the IDE, and select that serial port.

On Windows

The port is likely to be COM3 or higher and is called "Intel Galileo Gen 2 Virtual Com Port" in the Device Manager. It is NOT "USB Serial Port". COM1 and COM2 are usually reserved for hardware serial ports:


On Linux

The port is likely to be /dev/ttyACM1:


On Mac OS X

The port is likely to be /dev/cu.usbmodemxxxx. If you have multiple such devices, select any one of them as they should all give the same results:


Upload and Run your first Sketch

Click the Upload button in the upper left to load and run the sketch on your board:


You should see a Transfer complete message when it has uploaded. Now your built-in led should blink.


You have successfully set up your Intel® Edison board and uploaded your first sketch. You are ready to move on with our tutorials and projects: choose your next destination below.

Get inspired

Now that you have set up and programmed your Intel® Galileo Gen2 board, you may find inspiration in our Project Hub tutorial platform, or learn how to use the specific features of the Galileo board.

Here a list of tutorials that will help you in making very cool things!

Linux Tutorial For Intel® Galileo Gen 2
GSM Controlled Star Light
Touchscreen Controlled Marionette
Real-Time Lamp

Last revision 2016/08/10 by SM

The text of the Arduino getting started guide is licensed under a Creative Commons Attribution-ShareAlike 3.0 License. Code samples in the guide are released into the public domain.

Share