Guide.MacOSX History

Show minor edits - Show changes to markup

August 20, 2015, at 12:13 PM by Alice Pintus -
Changed lines 137-138 from:

Double-click the Arduino application. (Note: if the Arduino software loads in the wrong language, you can change it in the preferences dialog. See the environment page for details.)

to:

Double-click the Arduino application. (Note: if the Arduino software loads in the wrong language, you can change it in the preferences dialog. See the environment page for details.

August 20, 2015, at 12:11 PM by Alice Pintus -
Changed lines 85-86 from:

In this tutorial, we assume you're using an Arduino Uno, Arduino Duemilanove, Nano, Arduino Mega 2560 , or Diecimila. If you have another board, read the corresponding page in this getting started guide.

to:

In this tutorial, we assume you're using an Arduino Uno or Arduino Mega 2560. If you have another board, read the corresponding page in this getting started guide.

Deleted lines 110-111:
Changed lines 124-126 from:

The Arduino Uno, Mega, Duemilanove and Arduino Nano automatically draw power from either the USB connection to the computer or an external power supply. If you're using an Arduino Diecimila, you'll need to make sure that the board is configured to draw power from the USB connection. The power source is selected with a jumper, a small piece of plastic that fits onto two of the three pins between the USB and power jacks. Check that it's on the two pins closest to the USB port.

Connect the Arduino board to your computer using the USB cable. The green power LED (labelled PWR) should go on.

to:

The Arduino Uno, and Mega automatically draw power from either the USB connection to the computer or an external power supply. The power source is selected with a jumper, a small piece of plastic that fits onto two of the three pins between the USB and power jacks. Check that it's on the two pins closest to the USB port.

Connect the Arduino board to your computer using the USB cable. The green power LED (labelled PWR) should go on.

Deleted lines 134-136:
Changed lines 151-152 from:

Open the LED blink example sketch: File > Examples >01.Basics > Blink.

to:

Open the LED blink example sketch: File > Examples > 01.Basics > Blink.

Changed lines 178-179 from:

For Duemilanove Arduino boards with an ATmega328 (check the text on the chip on the board), select Arduino Duemilanove or Nano w/ ATmega328. Previously, Arduino boards came with an ATmega168; for those, select Arduino Diecimila, Duemilanove, or Nano w/ ATmega168. (Details of the board menu entries are available on the environment page.)

to:

Details of the board menu entries are available on the environment page.)

Changed lines 196-197 from:

8 | Select your serial port

to:

8 | Select your Serial Port

Changed lines 220-221 from:

Now, simply click the "Upload" button in the environment. Wait a few seconds - you should see the RX and TX leds on the board flashing. If the upload is successful, the message "Done uploading." will appear in the status bar. (Note: If you have an Arduino Mini, NG, or other board, you'll need to physically press the reset button on the board immediately before clicking the upload button on the Arduino Software.)

to:

Now, simply click the "Upload" button in the environment. Wait a few seconds - you should see the RX and TX LEDs on the board flashing. If the upload is successful, the message "Done uploading." will appear in the status bar. (Note: If you have an Arduino Mini, NG, or other board, you'll need to physically press the reset button on the board immediately before clicking the upload button on the Arduino Software.)

Changed lines 224-225 from:

A few seconds after the upload finishes, you should see the pin 13 (L) LED on the board start to blink (in orange). If it does, congratulations! You've gotten Arduino up-and-running. If you have problems, please see the troubleshooting suggestions.

to:

A few seconds after the upload finishes, you should see the pin 13 (L) LED on the board start to blink (in orange). If it does, congratulations! You've gotten Arduino up-and-running. If you have problems, please see the troubleshooting suggestions.

August 20, 2015, at 12:07 PM by Alice Pintus -
Changed lines 109-112 from:

If you're using an Arduino Uno or Mega 2560, you don't have any drivers to install. Skip ahead to the next step.

to:

If you're using an Arduino Uno or Mega 2560, you don't have any drivers to install.

August 20, 2015, at 12:06 PM by Alice Pintus -
Changed line 16 from:
     English (英语)
to:
     English
Changed line 20 from:
      <li class="selected">English (英语)</li>
to:
      <li class="selected">English </li>
Changed line 49 from:
      <li><a href="?setlang=en">English (英语)</a></li>
to:
      <li><a href="?setlang=en">英语 (English)</a></li>
Changed lines 111-116 from:
to:
August 10, 2015, at 01:37 PM by Simone Maiocchi -
Changed lines 93-94 from:

在这个教程里,我们假定你用的是一块 Genuino Uno. 如果你使用的是其他电路板,请在开始介绍手册里面阅读对应的内容。

to:

在这个教程里,我们默认你用的是一块 Genuino Uno. 如果你使用的是其他电路板,请在开始介绍手册里面阅读对应的内容。

Changed line 253 from:
to:
August 07, 2015, at 06:40 PM by Simone Maiocchi -
Deleted lines 179-180:
Changed lines 181-192 from:

8 | Select your serial port

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbmodem (for the Uno or Mega 2560) or /dev/tty.usbserial (for older boards) in it.

selecting an Uno, Mega2560, or newer board

selecting an older FTDI-based board

9 | Upload the program

to:

You'll need to select the entry in the Tools > Board menu that corresponds to your Arduino.

Selecting an Arduino Uno

For Duemilanove Arduino boards with an ATmega328 (check the text on the chip on the board), select Arduino Duemilanove or Nano w/ ATmega328. Previously, Arduino boards came with an ATmega168; for those, select Arduino Diecimila, Duemilanove, or Nano w/ ATmega168. (Details of the board menu entries are available on the environment page.)

Changed lines 192-199 from:
to:
Changed lines 205-215 from:

Now, simply click the "Upload" button in the environment. Wait a few seconds - you should see the RX and TX leds on the board flashing. If the upload is successful, the message "Done uploading." will appear in the status bar. (Note: If you have an Arduino Mini, NG, or other board, you'll need to physically press the reset button on the board immediately before clicking the upload button on the Arduino Software.)


A few seconds after the upload finishes, you should see the pin 13 (L) LED on the board start to blink (in orange). If it does, congratulations! You've gotten Arduino up-and-running. If you have problems, please see the troubleshooting suggestions.

You might also want to look at:

  • the examples for using various sensors and actuators
  • the reference for the Arduino language



to:

8 | Select your serial port

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbmodem (for the Uno or Mega 2560) or /dev/tty.usbserial (for older boards) in it.

selecting an Uno, Mega2560, or newer board

selecting an older FTDI-based board

9 | Upload the program

Changed lines 220-221 from:

现在,你只需要在Arduino软件(IDE)点击“上传”按钮. 稍等片刻,你就会看到板子上面标有RX和TX的LED灯在闪。 如果上传成功,状态栏会出现“上传成功”的字样。

to:
Changed lines 233-239 from:

上传完之后,你会很快看到板子13号针脚(L)的LED开始在闪。这证明上传成功了,你已经把Genuino和Arduino软件(IDE)跑起来了!

如果你有任何问题,请参考troubleshooting suggestions(英文).

你可能也想要去

to:

A few seconds after the upload finishes, you should see the pin 13 (L) LED on the board start to blink (in orange). If it does, congratulations! You've gotten Arduino up-and-running. If you have problems, please see the troubleshooting suggestions.

You might also want to look at:

  • the examples for using various sensors and actuators
  • the reference for the Arduino language
Added lines 240-254:
August 07, 2015, at 06:37 PM by Simone Maiocchi -
Deleted lines 158-159:
Changed lines 160-162 from:

7 | Select your board

to:

Open the LED blink example sketch: File > Examples >01.Basics > Blink.

Deleted line 163:
Changed lines 165-169 from:

7 | 选择开发板

to:

打开LED Blink 样例代码:文件>示例>01.Basics > Blink

Deleted lines 171-172:
Added lines 173-182:
Changed lines 206-233 from:
to:
August 07, 2015, at 06:18 PM by Simone Maiocchi -
Deleted lines 66-68:
Changed line 68 from:

1 | Get an Arduino board and USB cable

to:

This document explains how to connect your Arduino board to the computer and upload your first sketch.

Deleted line 69:
Changed line 71 from:

1 | 获得Arduino/Genuino开发板和USB连接线

to:

这个文档告诉你如何在Genuino板子上上传你的第一个程序到电脑上

Changed lines 74-75 from:
to:
Changed lines 76-91 from:
to:

1 | Get an Arduino board and USB cable

Changed lines 80-89 from:
to:
Changed lines 84-90 from:

If you're using the Arduino Uno or Arduino Mega 2560, a dialog box will appear telling you that a new network interface has been detected. Click "Network Preferences...", and when it opens, simply click "Apply". The Uno or Mega 2560 will show up as "Not Configured", but it's working properly. Quit System Preferences.

5 | Launch the Arduino application

Double-click the Arduino application. (Note: if the Arduino software loads in the wrong language, you can change it in the preferences dialog. See the environment page for details.)

6 | Open the blink example

to:

In this tutorial, we assume you're using an Arduino Uno, Arduino Duemilanove, Nano, Arduino Mega 2560 , or Diecimila. If you have another board, read the corresponding page in this getting started guide.

You also need a standard USB cable (A plug to B plug): the kind you would connect to a USB printer, for example. (For the Arduino Nano, you'll need an A to Mini-B cable instead.)

Changed lines 93-103 from:
to:

在这个教程里,我们假定你用的是一块 Genuino Uno. 如果你使用的是其他电路板,请在开始介绍手册里面阅读对应的内容。

你也可以用一条标准的USB线 (A 接口对B接口),比如说你连接到打印机USB接口用的线。 (对于Genuino Micro,你需要的是一条A 接口对MiniB接口的线)

Deleted lines 100-105:
Changed lines 102-113 from:

8 | Select your serial port

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbmodem (for the Uno or Mega 2560) or /dev/tty.usbserial (for older boards) in it.

selecting an Uno, Mega2560, or newer board

selecting an older FTDI-based board

9 | Upload the program

to:
Added lines 121-186:
August 07, 2015, at 02:15 PM by Simone Maiocchi -
Changed line 16 from:
      English
to:
     English (英语)
Changed lines 20-21 from:
      <li class="selected">English</li>
      <li><a href="?setlang=cn">中文</a></li>
to:
      <li class="selected">English (英语)</li>
      <li><a href="?setlang=cn">中文 (Chinese)</a></li>
Added line 25:
Changed line 42 from:
  <div class="language-dropdown columns large-2 medium-2">
to:
   <div class="language-dropdown columns large-2 medium-2">
Changed line 44 from:
      中文
to:
      中文 (Chinese)
Changed lines 48-49 from:
      <li class="selected">中文</li>
      <li><a href="?setlang=en">English</a></li>
to:
      <li class="selected">中文 (Chinese)</li>
      <li><a href="?setlang=en">English (英语)</a></li>
Added line 53:
August 05, 2015, at 04:38 PM by Simone Maiocchi -
Changed line 143 from:
to:
Changed line 157 from:
to:
August 05, 2015, at 04:37 PM by Simone Maiocchi -
Changed line 143 from:
to:
August 05, 2015, at 01:48 PM by Simone Maiocchi -
Added lines 34-40:

<div class="breadcrumb columns large-10 medium-10">

    <p>
      <a class="wikilink" href="/cn/Main/Landingpage">欢迎来到Genuino的世界  </a>
      > 入门指南  > MacOSX
    </p>
  </div>
August 05, 2015, at 01:45 PM by Simone Maiocchi -
Changed line 8 from:
      <a class="wikilink" href="/en/Guide">Getting Started </a>
to:
      <a class="wikilink" href="/en/Guide/HomePage">Getting Started </a>
August 05, 2015, at 01:43 PM by Simone Maiocchi -
Changed line 8 from:
      <a class="wikilink" href="/Guide">Getting Started </a>
to:
      <a class="wikilink" href="/en/Guide">Getting Started </a>
August 05, 2015, at 01:43 PM by Simone Maiocchi -
Added lines 6-13:

<div class="breadcrumb columns large-10 medium-10">

    <p>
      <a class="wikilink" href="/Guide">Getting Started </a>
      > MacOSX
    </p>
  </div>

August 04, 2015, at 07:10 PM by Simone Maiocchi -
Changed line 123 from:

(if lang en:)

to:
August 04, 2015, at 07:08 PM by Simone Maiocchi -
Deleted line 146:
August 04, 2015, at 07:08 PM by Simone Maiocchi -
Changed lines 75-76 from:
to:
Changed line 83 from:

2|下载Arduino软件(IDE)

to:

2 | 下载Arduino软件(IDE)

Changed line 86 from:

3|安装Arduino软件(IDE)

to:

3 | 安装Arduino软件(IDE)

Changed line 88 from:

4|连接开发板

to:

4 | 连接开发板

Changed line 105 from:

5|启动Arduino软件

to:

5 | 启动Arduino软件

Changed line 107 from:

6|打开闪烁示例

to:

6 | 打开闪烁示例

Changed line 118 from:

7|选择开发板

to:

7 | 选择开发板

Added line 123:

(if lang en:)

Changed lines 136-147 from:
to:
August 04, 2015, at 07:01 PM by Simone Maiocchi -
Added lines 103-110:
Added line 113:
Changed lines 115-120 from:
to:
August 04, 2015, at 06:59 PM by Simone Maiocchi -
Changed line 58 from:

1|获得Arduino/Genuino开发板和USB连接线

to:

1 | 获得Arduino/Genuino开发板和USB连接线

Added line 63:
Changed lines 80-90 from:
to:
Added line 93:
Changed lines 101-102 from:
to:
August 04, 2015, at 06:41 PM by Simone Maiocchi -
Added line 1:
Changed line 13 from:
      <li><a href="?setlang=cn">Chinese</a></li>
to:
      <li><a href="?setlang=cn">中文</a></li>
Deleted lines 18-21:
Changed lines 21-22 from:
to:
Changed lines 41-43 from:
to:
Changed line 43 from:

1 | Get an Arduino board and USB cable

to:

Getting Started w/ Arduino on Mac OS X

Changed line 47 from:

1|获得Arduino/Genuino开发板和USB连接线

to:

在Mac OS X系统上入门Arduino/ Genuino

Added lines 50-60:
August 04, 2015, at 05:56 PM by Simone Maiocchi -
Changed line 12 from:
      <li><a href="?setlang=cn">中文</a></li>
to:
      <li><a href="?setlang=cn">Chinese</a></li>
August 04, 2015, at 05:35 PM by Simone Maiocchi -
August 04, 2015, at 05:32 PM by Simone Maiocchi -
Changed line 12 from:
      <li><a href="?setlang=cn">Chinese</a></li>
to:
      <li><a href="?setlang=cn">中文</a></li>
August 04, 2015, at 05:25 PM by Simone Maiocchi -
Deleted line 0:
Added line 19:
August 04, 2015, at 05:19 PM by Simone Maiocchi -
Changed line 25 from:

!!在Mac OS X系统上入门Arduino/ Genuino

to:

在Mac OS X系统上入门Arduino/ Genuino

August 04, 2015, at 05:18 PM by Simone Maiocchi -
Deleted lines 5-11:
  <div class="breadcrumb columns large-10 medium-10">
    <p>
      <a class="wikilink" href="/en/Main/Products">ARDUINO/GENUINO PRODUCTS </a>
      > Products Warranty
    </p>
  </div>
August 04, 2015, at 05:17 PM by Simone Maiocchi -
Added lines 1-27:
Changed lines 29-34 from:
to:
Changed line 38 from:
to:
Changed lines 40-45 from:
to:
July 24, 2015, at 10:34 AM by Alice Pintus -
Changed lines 13-16 from:

Get the latest version from the download page.

When the download is finished, double click the .zip fle. This will expand the Arduino application.

to:

Get the latest version from the download page. When the download is finished, double click the .zip fle. This will expand the Arduino application.

February 06, 2015, at 07:10 PM by Katia De Coi -
Changed lines 22-27 from:

If you're using an older board (Duemilanove, Diecimila, or any board with an FTDI driver chip that looks like this:

you will need to install the drivers for the FTDI chip on the board. You need to download the latest version of the drivers from the FTDI website. One downloaded, double click the package, and follow the instructions in the installer. You'll need to restart your computer after installing the drivers.

to:
June 03, 2014, at 11:33 AM by Roberto Guido - fixed typo. Thanks to Peter Mortensen for notice
Changed lines 20-21 from:

If you're using an Arduino Uno or Mga 2560, you don't have any drivers to install. Skip ahead to the next step.

to:

If you're using an Arduino Uno or Mega 2560, you don't have any drivers to install. Skip ahead to the next step.

May 23, 2012, at 03:05 PM by David A. Mellis -
Changed lines 36-37 from:

Double-click the Arduino application.

to:

Double-click the Arduino application. (Note: if the Arduino software loads in the wrong language, you can change it in the preferences dialog. See the environment page for details.)

March 05, 2012, at 12:44 AM by Scott Fitzgerald -
Deleted lines 16-17:
March 05, 2012, at 12:44 AM by Scott Fitzgerald - added download to FTDI drivers, updated the download arduino section
Changed lines 15-16 from:

The disk image (.dmg) should mount automatically. If it doesn't, double-click it. It should look like the following image.

to:

When the download is finished, double click the .zip fle. This will expand the Arduino application.

Changed lines 28-29 from:

you will need to install the drivers for the FTDI chip on the board. Double-click the FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg icon and follow the instructions in the installer. You'll need to restart your computer after installing the drivers. (The latest version of the drivers can be found on the FTDI website.)

to:

you will need to install the drivers for the FTDI chip on the board. You need to download the latest version of the drivers from the FTDI website. One downloaded, double click the package, and follow the instructions in the installer. You'll need to restart your computer after installing the drivers.

Changed line 61 from:
to:
October 26, 2010, at 05:47 PM by David A. Mellis -
Changed lines 50-51 from:

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbmodem (for the Uno) or /dev/tty.usbmodem (for older boards) in it.

to:

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbmodem (for the Uno or Mega 2560) or /dev/tty.usbserial (for older boards) in it.

October 16, 2010, at 09:03 PM by David A. Mellis -
Added lines 34-35:

If you're using the Arduino Uno or Arduino Mega 2560, a dialog box will appear telling you that a new network interface has been detected. Click "Network Preferences...", and when it opens, simply click "Apply". The Uno or Mega 2560 will show up as "Not Configured", but it's working properly. Quit System Preferences.

September 29, 2010, at 09:09 PM by Tom Igoe -
Changed lines 48-49 from:

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

to:

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbmodem (for the Uno) or /dev/tty.usbmodem (for older boards) in it.

selecting an Uno, Mega2560, or newer board

selecting an older FTDI-based board

September 29, 2010, at 08:57 PM by Tom Igoe -
Changed lines 26-27 from:

Attach: FTDIChip.png

to:
September 29, 2010, at 08:56 PM by Tom Igoe -
Changed lines 19-20 from:

3 | Install the Application and USB drivers

to:

3 | Install the Software

Changed lines 22-24 from:

If this is your first time using an Arduino with your computer, you will need to install the drivers for the FTDI chip on the board. Double-click the FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg icon and follow the instructions in the installer. You'll need to restart your computer after installing the drivers. (The latest version of the drivers can be found on the FTDI website.)

to:

If you're using an Arduino Uno or Mga 2560, you don't have any drivers to install. Skip ahead to the next step.

If you're using an older board (Duemilanove, Diecimila, or any board with an FTDI driver chip that looks like this:

Attach: FTDIChip.png

you will need to install the drivers for the FTDI chip on the board. Double-click the FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg icon and follow the instructions in the installer. You'll need to restart your computer after installing the drivers. (The latest version of the drivers can be found on the FTDI website.)

February 06, 2010, at 12:52 AM by David A. Mellis -
Changed lines 5-14 from:
  1. Get an Arduino board and USB cable
  2. Download the Arduino environment
  3. Install the USB drivers
  4. Connect the board
  5. Launch the Arduino application
  6. Open the blink example
  7. Select your board
  8. Select the serial port
  9. Upload the program
to:
February 06, 2010, at 12:49 AM by David A. Mellis -
February 06, 2010, at 12:48 AM by David A. Mellis -
Added lines 15-16:

1 | Get an Arduino board and USB cable

February 06, 2010, at 12:42 AM by David A. Mellis -
Changed lines 9-11 from:
  1. Run the Arduino environment
  2. Upload a program
to:
  1. Launch the Arduino application
  2. Open the blink example
  3. Select your board
  4. Select the serial port
  5. Upload the program
Changed lines 34-35 from:

5 | Launch Arduino and open an example

to:

5 | Launch the Arduino application

Added lines 38-39:

6 | Open the blink example

Changed lines 42-45 from:

6 | Upload a program

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

to:

7 | Select your board

Added lines 46-51:

8 | Select your serial port

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

9 | Upload the program

February 06, 2010, at 12:40 AM by David A. Mellis -
Added lines 41-42:
February 06, 2010, at 12:37 AM by David A. Mellis -
Changed lines 11-13 from:
  1. Look for the blinking LED
  2. Learn to use Arduino
to:
February 06, 2010, at 12:34 AM by David A. Mellis -
Added lines 39-40:

6 | Upload a program

February 06, 2010, at 12:34 AM by David A. Mellis -
Added lines 33-36:

5 | Launch Arduino and open an example

Double-click the Arduino application.

February 06, 2010, at 12:33 AM by David A. Mellis -
Changed lines 5-6 from:
to:
  1. Get an Arduino board and USB cable
  2. Download the Arduino environment
  3. Install the USB drivers
  4. Connect the board
  5. Run the Arduino environment
  6. Upload a program
  7. Look for the blinking LED
  8. Learn to use Arduino
Added lines 29-30:

4 | Connect the board

February 06, 2010, at 12:01 AM by David A. Mellis -
Changed lines 1-2 from:

How To Get Arduino Running on Mac OS X (10.3.9 or later)

to:

Getting Started w/ Arduino on Mac OS X

February 06, 2010, at 12:00 AM by David A. Mellis -
Changed lines 13-14 from:

The disk image (.dmg) should mount automatically. If it doesn't, double-click it. It should like the following image.

to:

The disk image (.dmg) should mount automatically. If it doesn't, double-click it. It should look like the following image.

Changed lines 20-21 from:

If this is your first time using an Arduino board on this computer, you will need to install the drivers for the FTDI chip on the board. Double-click the FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg icon and follow the instructions in the installer. You'll need to restart your computer after installing the drivers. (The latest version of the drivers can be found on the FTDI website.)

to:

If this is your first time using an Arduino with your computer, you will need to install the drivers for the FTDI chip on the board. Double-click the FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg icon and follow the instructions in the installer. You'll need to restart your computer after installing the drivers. (The latest version of the drivers can be found on the FTDI website.)

February 05, 2010, at 11:58 PM by David A. Mellis -
Changed lines 13-14 from:

The disk image (.dmg) should mount automatically. If it doesn't, double-click it.

to:

The disk image (.dmg) should mount automatically. If it doesn't, double-click it. It should like the following image.

Changed lines 17-25 from:

3 | Install the USB drivers

If you are using a USB Arduino, you will need to install the drivers for the FTDI chip on the board. These can be found in the drivers directory of the Arduino distribution.

You'll need to select the correct drivers for your computer. Use:

  • FTDIUSBSerialDriver_v2_1_9.dmg for older (PPC) Macs like the Powerbook, iBook, G4 or G5
  • FTDIUSBSerialDriver_v2_2_9_Intel.dmg for newer (Intel) Macs like the MacBook, MacBook Pro, or Mac Pro

(The latest version of the drivers can be found on the FTDI website.)

to:

3 | Install the Application and USB drivers

Copy the Arduino application into the Applications folder (or elsewhere on your computer).

If this is your first time using an Arduino board on this computer, you will need to install the drivers for the FTDI chip on the board. Double-click the FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg icon and follow the instructions in the installer. You'll need to restart your computer after installing the drivers. (The latest version of the drivers can be found on the FTDI website.)

February 05, 2010, at 11:53 PM by David A. Mellis -
Changed lines 9-10 from:
to:

2 | Download the Arduino environment

Get the latest version from the download page.

The disk image (.dmg) should mount automatically. If it doesn't, double-click it.

May 21, 2009, at 02:51 PM by David A. Mellis -
Changed lines 24-25 from:

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

to:

Select the serial device of the Arduino board from the Tools > Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

May 21, 2009, at 02:50 PM by David A. Mellis -
Changed lines 24-27 from:

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

to:

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

May 21, 2009, at 02:47 PM by David A. Mellis -
Changed lines 24-25 from:

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

to:

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something with /dev/tty.usbserial in it.

May 21, 2009, at 02:44 PM by David A. Mellis -
Deleted lines 21-22:
May 21, 2009, at 02:36 PM by David A. Mellis -
Changed lines 15-17 from:
  • the PPC drivers FTDIUSBSerialDriver_v2_1_9.dmg for older Macs like the Powerbook, iBook, G4 or G5
  • the Intel drivers FTDIUSBSerialDriver_v2_2_9_Intel.dmg for newer Macs like the MacBook, MacBook Pro, or Mac Pro
to:
  • FTDIUSBSerialDriver_v2_1_9.dmg for older (PPC) Macs like the Powerbook, iBook, G4 or G5
  • FTDIUSBSerialDriver_v2_2_9_Intel.dmg for newer (Intel) Macs like the MacBook, MacBook Pro, or Mac Pro
May 21, 2009, at 02:36 PM by David A. Mellis -
Changed lines 14-17 from:

If you have an older Mac like a Powerbook, iBook, G4 or G5, you should use the the PPC drivers: FTDIUSBSerialDriver_v2_1_9.dmg. If you have a newer Mac like an MacBook, MacBook Pro, or Mac Pro, you need the Intel drivers: FTDIUSBSerialDriver_v2_2_9_Intel.dmg. Double-click to mount the disk image and run the included FTDIUSBSerialDriver.pkg.

to:

You'll need to select the correct drivers for your computer. Use:

  • the PPC drivers FTDIUSBSerialDriver_v2_1_9.dmg for older Macs like the Powerbook, iBook, G4 or G5
  • the Intel drivers FTDIUSBSerialDriver_v2_2_9_Intel.dmg for newer Macs like the MacBook, MacBook Pro, or Mac Pro
June 02, 2008, at 01:28 AM by David A. Mellis -
Added lines 3-4:
June 02, 2008, at 01:18 AM by David A. Mellis -
Changed lines 7-13 from:

2 | Download the Arduino environment

To program the Arduino board you need the Arduino environment.

Download: the latest version of the software from the download page

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder with the Arduino software in side. Double-click the folder to open it.

to:
June 02, 2008, at 01:14 AM by David A. Mellis -
Changed lines 8-13 from:

To program the Arduino board you need the Arduino environment. If you have an older Mac like a Powerbook, iBook, G4 or G5, you need the Arduino for PPC. If you have a newer Mac like an MacBook, MacBook Pro, or Mac Pro, you need the Intel version.

Download: Arduino 0011

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0011. Double-click the folder to open it.

to:

To program the Arduino board you need the Arduino environment.

Download: the latest version of the software from the download page

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder with the Arduino software in side. Double-click the folder to open it.

Changed lines 17-18 from:

On the Mac, mount the FTDIUSBSerialDriver_v2_1_9.dmg (on PPC machines) or the FTDIUSBSerialDriver_v2_2_9_Intel.dmg (on Intel machines) disk image and run the included FTDIUSBSerialDriver.pkg.

to:

If you have an older Mac like a Powerbook, iBook, G4 or G5, you should use the the PPC drivers: FTDIUSBSerialDriver_v2_1_9.dmg. If you have a newer Mac like an MacBook, MacBook Pro, or Mac Pro, you need the Intel drivers: FTDIUSBSerialDriver_v2_2_9_Intel.dmg. Double-click to mount the disk image and run the included FTDIUSBSerialDriver.pkg.

March 28, 2008, at 11:54 PM by David A. Mellis -
Changed lines 10-13 from:

Download: Arduino 0010

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0009. Double-click the folder to open it.

to:

Download: Arduino 0011

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0011. Double-click the folder to open it.

Changed lines 17-18 from:

On the Mac, mount the FTDIUSBSerialDriver_v2_1_6.dmg (on PPC machines) or the FTDIUSBSerialDriver_v2_2_6_Intel.dmg (on Intel machines) disk image and run the included FTDIUSBSerialDriver.pkg.

to:

On the Mac, mount the FTDIUSBSerialDriver_v2_1_9.dmg (on PPC machines) or the FTDIUSBSerialDriver_v2_2_9_Intel.dmg (on Intel machines) disk image and run the included FTDIUSBSerialDriver.pkg.

March 27, 2008, at 11:38 PM by David A. Mellis -
Changed lines 10-11 from:

Download: Arduino 0009 for PPC or Arduino 0009 for Intel

to:

Download: Arduino 0010

August 07, 2007, at 03:45 AM by David A. Mellis - updating software version to 0009.
Changed lines 10-11 from:

Download: Arduino 0008 for PPC or Arduino 0008 for Intel

to:

Download: Arduino 0009 for PPC or Arduino 0009 for Intel

June 10, 2007, at 01:55 AM by David A. Mellis -
Changed lines 12-13 from:

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0007. Double-click the folder to open it.

to:

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0008. Double-click the folder to open it.

June 10, 2007, at 01:54 AM by David A. Mellis -
Changed lines 10-11 from:

Download: Arduino 0007 for PPC or Arduino 0007 for Intel

to:

Download: Arduino 0008 for PPC or Arduino 0008 for Intel

March 03, 2007, at 09:11 PM by David A. Mellis -
Added lines 25-26:
December 26, 2006, at 01:28 AM by David A. Mellis - removing reference to macosx_setup.command and updating links to point to 0007.
Changed lines 10-17 from:

Download: Arduino 0006 for PPC or Arduino 0006 for Intel

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0006. Double-click the folder to open it.

Then, double-click macosx_setup.command. This will open a Terminal and ask you if you want to continue. Type y and press return. When prompted, type your password and press return.

to:

Download: Arduino 0007 for PPC or Arduino 0007 for Intel

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0007. Double-click the folder to open it.

December 04, 2006, at 11:35 PM by David A. Mellis -
Changed lines 12-13 from:

After downloading the IDE, run the macosx_setup.command. It corrects permission on a few files for use with the serial port and will prompt you for your password. You may need to reboot after running this script.

to:

When the download finishes, unzip the downloaded file by double-clicking it. This should create a folder called arduino-0006. Double-click the folder to open it.

Then, double-click macosx_setup.command. This will open a Terminal and ask you if you want to continue. Type y and press return. When prompted, type your password and press return.

Changed lines 19-20 from:

If you are using a USB Arduino, you will need to install the drivers for the FTDI chip on the board. These can be found in the drivers directory of the Arduino distribution.

to:

If you are using a USB Arduino, you will need to install the drivers for the FTDI chip on the board. These can be found in the drivers directory of the Arduino distribution.

Changed lines 25-26 from:

The latest version of the drivers can be found on the FTDI website.

to:

(The latest version of the drivers can be found on the FTDI website.)

December 04, 2006, at 11:31 PM by David A. Mellis - linking directly to the Arduino downloads.
Changed lines 7-8 from:
to:

2 | Download the Arduino environment

To program the Arduino board you need the Arduino environment. If you have an older Mac like a Powerbook, iBook, G4 or G5, you need the Arduino for PPC. If you have a newer Mac like an MacBook, MacBook Pro, or Mac Pro, you need the Intel version.

Download: Arduino 0006 for PPC or Arduino 0006 for Intel

November 16, 2006, at 11:48 PM by David A. Mellis -
Added lines 24-29:
November 04, 2006, at 02:01 PM by David A. Mellis -
Deleted lines 24-25:
November 04, 2006, at 01:53 PM by David A. Mellis -
Changed lines 1-31 from:

Arduino Howto

These are the steps you need to follow in order to be up and running:

  1. Get an Arduino board
  2. Download the Arduino environment
  3. Install the USB drivers
  4. Connect the board
  5. Upload a program

1 | Get an Arduino board

The Arduino i/o board is a simple circuit featuring the ATmega8 processor from Atmel. The board is composed of a printed circuit board (PCB) and electronic parts.

There are a few ways to get an Arduino board:

  • buy a ready made board. See how you can buy a board or just the PCB.
    • European distributor
    • US distributor
  • build your own board. If you want you can build your own PCB just by downloading the CAD files from the Hardware page. Extract the .brd file and send it to a PCB manufacturer. Be aware that manufacturing a single pcb will be very expensive. It's better to get together with other people and make 20 or 30 at a time. Since you get the full CAD files you can make your own customised version of Arduino. if you make modifications or fix bugs please send us your changes!
    • purchase parts. purchase the parts from any electronics store. The Serial version in particular has been designed to use the most basic parts that can be found anywhere in the world. The USB version on the other hand requires some advanced soldering skills because of the FTDI chip that is an smd part. Here is a list? of parts for the serial board.
    • assemble the board. We put together a step by step guide on how to build an arduino board. Newbies: never soldered before? afraid of trashing thousands of boards before getting one properly soldered? fear not :) learn to master the art of soldering.
    • program the bootloader. In order for the development environment to be able to program the chip, this has to be programmed with a piece of code called bootloader. See the bootloader page on how to program it on your chip.

2 | Download the Arduino environment

To program the Arduino board you need the Arduino environment.

Download Arduino: From the software page.

to:
Deleted lines 12-13:

For more information, see the guide to the Arduino environment.

Changed lines 22-66 from:

4 | Connect the board

If you're using a serial board, power the board with an external power supply (6 to 25 volts DC, with the core of the connector positive). Connect the board to a serial port on your computer.

On the USB boards, the power source is selected by the jumper between the USB and power plugs. To power the board from the USB port (good for controlling low power devices like LEDs), place the jumper on the two pins closest to the USB plug. To power the board from an external power supply (needed for motors and other high current devices), place the jumper on the two pins closest to the power plug. Either way, connect the board to a USB port on your computer.

The power LED should go on.

5 | Upload a program

Open the LED blink example sketch: File > Sketchbook > Examples > led_blink.

Here's what the code for the LED blink example looks like.

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something like /dev/cu.usbserial-1B1 for a USB board, or something like /dev/cu.USA19QW1b1P1.1 if using a Keyspan adapter with a serial board (other USB-to-serial adapters use different names).

Push the reset button on the board then click the Upload button in the IDE. Wait a few seconds. If successful, the message "Done uploading." will appear in the status bar.

If the Arduino board doesn't show up in the Tools | Serial Port menu, or you get an error while uploading, please see the troubleshooting suggestions.

A few seconds after the upload finishes, you should see the amber (yellow) LED on the board start to blink.

Learn More

  • Read about the Arduino Environment
  • Learn about the parts of the Arduino board
  • See the tutorials for some example programs. (There are also some examples available in the examples directory inside the arduino directory.)
  • Look up specific Arduino functions and syntax in the reference
  • The Arduino programming language is compatible with the Wiring language allowing porting applications from the Wiring board to Arduino. Please note the differences between the Wiring and Processing languages.
  • If you're having problems, check the FAQ.
  • If you don't find a solution there, try posting in the forums.

to:
November 04, 2006, at 01:42 PM by David A. Mellis -
Added lines 1-91:

Arduino Howto

These are the steps you need to follow in order to be up and running:

  1. Get an Arduino board
  2. Download the Arduino environment
  3. Install the USB drivers
  4. Connect the board
  5. Upload a program

1 | Get an Arduino board

The Arduino i/o board is a simple circuit featuring the ATmega8 processor from Atmel. The board is composed of a printed circuit board (PCB) and electronic parts.

There are a few ways to get an Arduino board:

  • buy a ready made board. See how you can buy a board or just the PCB.
    • European distributor
    • US distributor
  • build your own board. If you want you can build your own PCB just by downloading the CAD files from the Hardware page. Extract the .brd file and send it to a PCB manufacturer. Be aware that manufacturing a single pcb will be very expensive. It's better to get together with other people and make 20 or 30 at a time. Since you get the full CAD files you can make your own customised version of Arduino. if you make modifications or fix bugs please send us your changes!
    • purchase parts. purchase the parts from any electronics store. The Serial version in particular has been designed to use the most basic parts that can be found anywhere in the world. The USB version on the other hand requires some advanced soldering skills because of the FTDI chip that is an smd part. Here is a list? of parts for the serial board.
    • assemble the board. We put together a step by step guide on how to build an arduino board. Newbies: never soldered before? afraid of trashing thousands of boards before getting one properly soldered? fear not :) learn to master the art of soldering.
    • program the bootloader. In order for the development environment to be able to program the chip, this has to be programmed with a piece of code called bootloader. See the bootloader page on how to program it on your chip.

2 | Download the Arduino environment

To program the Arduino board you need the Arduino environment.

Download Arduino: From the software page.

After downloading the IDE, run the macosx_setup.command. It corrects permission on a few files for use with the serial port and will prompt you for your password. You may need to reboot after running this script.

For more information, see the guide to the Arduino environment.

3 | Install the USB drivers

If you are using a USB Arduino, you will need to install the drivers for the FTDI chip on the board. These can be found in the drivers directory of the Arduino distribution.

On the Mac, mount the FTDIUSBSerialDriver_v2_1_6.dmg (on PPC machines) or the FTDIUSBSerialDriver_v2_2_6_Intel.dmg (on Intel machines) disk image and run the included FTDIUSBSerialDriver.pkg.

The latest version of the drivers can be found on the FTDI website.

4 | Connect the board

If you're using a serial board, power the board with an external power supply (6 to 25 volts DC, with the core of the connector positive). Connect the board to a serial port on your computer.

On the USB boards, the power source is selected by the jumper between the USB and power plugs. To power the board from the USB port (good for controlling low power devices like LEDs), place the jumper on the two pins closest to the USB plug. To power the board from an external power supply (needed for motors and other high current devices), place the jumper on the two pins closest to the power plug. Either way, connect the board to a USB port on your computer.

The power LED should go on.

5 | Upload a program

Open the LED blink example sketch: File > Sketchbook > Examples > led_blink.

Here's what the code for the LED blink example looks like.

Select the serial device of the Arduino board from the Tools | Serial Port menu. On the Mac, this should be something like /dev/cu.usbserial-1B1 for a USB board, or something like /dev/cu.USA19QW1b1P1.1 if using a Keyspan adapter with a serial board (other USB-to-serial adapters use different names).

Push the reset button on the board then click the Upload button in the IDE. Wait a few seconds. If successful, the message "Done uploading." will appear in the status bar.

If the Arduino board doesn't show up in the Tools | Serial Port menu, or you get an error while uploading, please see the troubleshooting suggestions.

A few seconds after the upload finishes, you should see the amber (yellow) LED on the board start to blink.

Learn More

  • Read about the Arduino Environment
  • Learn about the parts of the Arduino board
  • See the tutorials for some example programs. (There are also some examples available in the examples directory inside the arduino directory.)
  • Look up specific Arduino functions and syntax in the reference
  • The Arduino programming language is compatible with the Wiring language allowing porting applications from the Wiring board to Arduino. Please note the differences between the Wiring and Processing languages.
  • If you're having problems, check the FAQ.
  • If you don't find a solution there, try posting in the forums.

Share