在Mac OS X系统上入门Arduino/ Genuino

这个文档告诉你如何在Genuino板子上上传你的第一个程序到电脑上

1 | 获得Arduino/Genuino开发板和USB连接线

在这个教程里,我们默认你用的是一块 Genuino Uno. 如果你使用的是其他电路板,请在开始介绍手册里面阅读对应的内容。

你也可以用一条标准的USB线 (A 接口对B接口),比如说你连接到打印机USB接口用的线。 (对于Genuino Micro,你需要的是一条A 接口对MiniB接口的线)

2 | 下载Arduino软件(IDE)

通过下载页面下载最新版Arduino软件(IDE)。 下载完成后,双击zip文件以解压文件。这将能扩展Arduino应用程序。

3 | 安装Arduino软件(IDE)

将Arduino应用程序复制到Application文件夹(或您电脑中的其他位置)中。

4 | 连接开发板

Genuino UNO, Mega 2560 和Micro能自动通过连接到电脑的USB线或者外部的供电来获取电源。你可以用USB电源给板子供电。

当你用USB线把Genuino板子和电脑连接起来后,你会看到电路板上面绿色的LED(标注着“PWR”)被点亮。

将会出现一个对话框,显示已检测到新的网络接口。点击“网络首选项”,打开后,只需点击“应用”即可。Arduino/Genuino开发板将会显示为“未配置”状态,但实际上开发板正在正常运行。退出系统设置。

5 | 启动Arduino软件

双击Arduino应用程序。(注:若Arduino软件(IDE)加载所用语言不适合,您可以通过系统配置对话框更改设置)。更多详细信息,请参考Arduino 软件(IDE)页面

6 | 打开闪烁示例

打开LED Blink 样例代码:文件>示例>01.Basics > Blink

7 | 选择开发板

你将需要在工具> 板 菜单选择对应的Genuino板子,上面会列着Arduino/Genuino以及板子的类型(Uno, Mega 2560 or Micro).

选择Arduino/Genuino Uno板子

具体的电路板选项请参考这个页面 在环境页面.

8 | 选择串行端口

从“工具>串口”菜单中选择Arduino/ Genuino开发板的串口设备。对于Mac设备,则应该是“/dev/tty.usbmodem”(用于Arduino/ Genuino Uno或Arduino/ Genuino Mega 2560)。

 [选择Uno、 Mega 2560或更高版本的开发板]

9|上传程序

现在,你只需要在Arduino软件(IDE)点击“上传”按钮. 稍等片刻,你就会看到板子上面标有RX和TX的LED灯在闪。 如果上传成功,状态栏会出现“上传成功”的字样。


上传完之后,你会很快看到板子13号针脚(L)的LED开始在闪。这证明上传成功了,你已经把Genuino和Arduino软件(IDE)跑起来了!

如果你有任何问题,请参考troubleshooting suggestions(英文).

你可能也想要去



此网页的内容已从知识共享署名 - 相同方式共享3.0许可协议 版获得了许可。当中的代码样例 在公共领域发表。

Share